Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

JoomlaTune Support Forum    JComments component    Integration with third-party extensions    CommunityBuilder    Topic: JComments Latest Comments CB Avatar breaks web page
Pages: [1]   Go Down
  Print  
Author Topic: JComments Latest Comments CB Avatar breaks web page  (Read 20655 times)
0 Members and 1 Guest are viewing this topic.
cliffvt
Newbie
*

Karma: 1
Offline Offline

Posts: 4


« on: January 05, 2014, 04:21:54 »

Hi There

Have JComments running perfectly on J3.2 wth CB 1.9.1 - displaying Latest comments on some pages - then I installed JCOmments Avatar plugin with Community Builder avatar option, and changed Latest Comments module to "show avatar"

Now it breaks the page completely, even making the Logo disappear - I can't find the reason, but when I turn off show avatar, then it works again.

General tab, Support plugins set to yes.

Any ideas?

Thanks

Cliff
« Last Edit: January 05, 2014, 04:24:49 by cliffvt » Logged
cliffvt
Newbie
*

Karma: 1
Offline Offline

Posts: 4


« Reply #1 on: January 10, 2014, 17:08:19 »

Found the issue - its an oversight in the code for Joomla 3.2 compatibility!

The problem file is /plugins/jcomments/avatar/avatar.php

I had to replace line 469 of that file, from:

Code:
require_once(JPATH_SITE . '/includes/application.php');

Which is no longer supported by Jomla 3.2, with

Code:
$app = JFactory::getApplication('site');

It now works!

Can the Joomlatune team please make this change for Joomla 3.2?

Thanks

Cliff
Logged
loku
Newbie
*

Karma: 0
Offline Offline

Posts: 1


« Reply #2 on: March 21, 2014, 01:47:41 »

 Cheesy
Found the issue - its an oversight in the code for Joomla 3.2 compatibility!

The problem file is /plugins/jcomments/avatar/avatar.php

I had to replace line 469 of that file, from:

Code:
require_once(JPATH_SITE . '/includes/application.php');

Which is no longer supported by Jomla 3.2, with

Code:
$app = JFactory::getApplication('site');

It now works!

Can the Joomlatune team please make this change for Joomla 3.2?

Thanks

Cliff

Thanks cliff. I just registered to thankyou for this solution.
My site breaked only when there is an open session. Also i was using CB avatars.
Logged
Pages: [1]   Go Up
  Print  
JoomlaTune Support Forum    JComments component    Integration with third-party extensions    CommunityBuilder    Topic: JComments Latest Comments CB Avatar breaks web page
 
Jump to: