Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length

JoomlaTune Support Forum    JComments component    Integration with third-party extensions    Topic: Cannot see all avatars - Solved
Pages: [1]   Go Down
  Print  
Author Topic: Cannot see all avatars - Solved  (Read 16286 times)
0 Members and 1 Guest are viewing this topic.
112358oo
Newbie
*

Karma: 0
Offline Offline

Posts: 8



« on: September 06, 2011, 20:43:19 »

Hi there! Jcomments is still the best extension for Joomla comments. Smiley

I have one problem. I cannot see all avatars in comments and in JComments Latest. Some users are working fine, some others always have no_avatar.png instead of any uploaded picture.

What could be wrong?

I am using:
JComments 2.2.0.2 [12/09/2010]
JComments Latest 2.5.6 for Joomla 1.5.x
JComments Latest Backend 1.0 for Joomla 1.5.x
JComments Avatars 3.1 for Joomla 1.5.x
with:
Mighty Resources Version 1.5.9 Build 7330
Mighty Touch 1.2.5 Build 6950
Mighty Registration 2.9.34 Build 6948
Mighty Message 1.0.5 Build 6946

Other data:
Database Version: 5.1.56-log
Database Collation: utf8_general_ci
PHP Version: 5.3.8
Web Server: Apache
Web Server to PHP interface: cgi-fcgi
Joomla! Version: Joomla! 1.5.23 Stable

Thanks.
« Last Edit: October 21, 2011, 19:58:34 by 112358oo » Logged
112358oo
Newbie
*

Karma: 0
Offline Offline

Posts: 8



« Reply #1 on: September 11, 2011, 02:17:16 »

This cannot be Mighty Extensions problem as I am seeing all avatars in posts/contents and community pages generated by ME. The only problem I have with JComments and strangely enough, with some users, not with all. This partial malfunction is bother me the most, I cannot see what could be a problem?

Edit: The problem occurred after upgrade of JComments 2.1 to 2.2 version.
Edit2: Look's like problem exists with the JComments 2.1 and the latest ME Resource 1.5.9
« Last Edit: October 14, 2011, 00:24:25 by 112358oo » Logged
smart
Administrator
Hero Member
*****

Karma: 188
Offline Offline

Gender: Male
Posts: 1883



WWW
« Reply #2 on: October 07, 2011, 19:14:16 »

Could you compare links to working and non-working avatars (i.e. find some user who has avatar in ME and which doesn't displayed in JComments and show me link to this avatar). In my mind these avatars could have different paths...
Logged

If you use JComments, please post a rating and a review at the Joomla! Extensions Directory
112358oo
Newbie
*

Karma: 0
Offline Offline

Posts: 8



« Reply #3 on: October 13, 2011, 20:23:13 »

Hi Smart! Thank you for your reply.

In this post (http://www.blogging4change.net/index.php?option=com_resource&controller=article&article=1583&category_id=1&Itemid=231) I have only two comments, one has avatar, the other one doesn't.

working fine:
http://www.blogging4change.net/administrator/components/com_juser/avatars/112358oo.jpg

not working fine:
http://www.gravatar.com/avatar.php?gravatar_id=af76dd34f8152b3e5e4e9c90c2789092&default=http%3A%2F%2Fwww.blogging4change.net%2Fcomponents%2Fcom_jcomments%2Fimages%2Fno_avatar.png

If I disable gravatar in JComments - Avatar and for NoAvatar choose default image I get this for the second one:
http://www.blogging4change.net/components/com_jcomments/images/no_avatar.png

Could be of help info that I got after I had validated my site: http://validator.w3.org/check?uri=http%3A%2F%2Fwww.blogging4change.net%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

I can see that controller function is not working properly when it comes to avatar...

Regards,
Igor
Logged
smart
Administrator
Hero Member
*****

Karma: 188
Offline Offline

Gender: Male
Posts: 1883



WWW
« Reply #4 on: October 13, 2011, 20:27:06 »

This is because one user has uploaded avatar into JUser extension but other user hasn't and gravatar is shown instead avatar.
Logged

If you use JComments, please post a rating and a review at the Joomla! Extensions Directory
112358oo
Newbie
*

Karma: 0
Offline Offline

Posts: 8



« Reply #5 on: October 13, 2011, 20:53:29 »

Thank you.

Both of users have avatars uploaded.

Here is the avatar for the second one:

http://www.blogging4change.net/administrator/components/com_juser/avatars/Anjale.jpg

Could it be something else?

Here is what I get when I validate:
Line 926, Column 81: cannot generate system identifier for general entity "controller"
…e.net/index2.php?option=com_community&controller=profile&task=avatar&no_ajax=1…
Logged
smart
Administrator
Hero Member
*****

Karma: 188
Offline Offline

Gender: Male
Posts: 1883



WWW
« Reply #6 on: October 14, 2011, 03:34:22 »

Hm... So both users have avatars, both avatars stored in the same folder... Could you compare file permissions for avatar's? I really have no idea why one is shown but other no...
Logged

If you use JComments, please post a rating and a review at the Joomla! Extensions Directory
112358oo
Newbie
*

Karma: 0
Offline Offline

Posts: 8



« Reply #7 on: October 15, 2011, 06:00:12 »

Both of avatars have same permissions: 644.

I noticed an interesting thing, non-working avatars have the username starting with the capital letter.

In other words, avatar:
http://www.blogging4change.net/administrator/components/com_juser/avatars/Anjale.jpg
doesn't work.

But, if I change the username into anjale and upload the same avatar again, then avatar:
http://www.blogging4change.net/administrator/components/com_juser/avatars/anjale.jpg
is working fine.

Is there something that I can do to correct this?
Logged
smart
Administrator
Hero Member
*****

Karma: 188
Offline Offline

Gender: Male
Posts: 1883



WWW
« Reply #8 on: October 18, 2011, 14:01:38 »

I noticed an interesting thing, non-working avatars have the username starting with the capital letter.
What JComments Avatar version do you use? if you're using JComments Avatar 3.5 you can try next fix:

1. Open file jcomments.avatar.php
2. Replace code:
Code: (php)
$avatar = $avatarsPath.'/'.strtolower($avatars[$userid]->avatar).'.jpg';
with
Code: (php)
$avatar = $avatarsPath.'/'.$avatars[$userid]->avatar.'.jpg';
Logged

If you use JComments, please post a rating and a review at the Joomla! Extensions Directory
112358oo
Newbie
*

Karma: 0
Offline Offline

Posts: 8



« Reply #9 on: October 21, 2011, 19:57:41 »

Thank you smart!

I did as you said and it's working. Cheesy
Logged
spiderbr
Newbie
*

Karma: 0
Offline Offline

Posts: 1


Email
« Reply #10 on: August 03, 2012, 18:56:35 »

Hello no download available for joomla 2.5?
Logged
Pages: [1]   Go Up
  Print  
JoomlaTune Support Forum    JComments component    Integration with third-party extensions    Topic: Cannot see all avatars - Solved
 
Jump to: